TTC Activation- Troubleshooting

TicTie Calculate version 4.6, 5.x and 6.x. See our How to Check Your Version article for more information. To upgrade from version 4.6 to version 5.x please reach out to support@safesend.com

Some users may experience issues with TicTie & Calculate activating and/or staying activated. This is due to a security setting in Adobe® that disables third-party applications like ours. These scenarios are outlined below:

  • The user activates the program, but then when they attempt to use a tool, like a calculator, they are be prompted to activate again.  This is due to a security setting in Adobe® that disables third-party applications like ours.
  • After installing the program, the plug-in does not display in Adobe®. 
  • When trying to sign in to version 5.x or 6.x, they receive the message "Error Contacting Server. Check Internet Connection."

This article outlines the steps to disable that setting so you can use the program.

Disable Protected Mode

  1. Click Menu or Edit in Adobe Acrobat®, depending on your version/view. 
  2. Click Preferences                                                                                                             TTCTTC56.png
  3. Select Security (Enhanced) in the Categories panel on the left.
  4. Uncheck Enable Protected Mode at startup (Preview).
  5. Click OK.

Enable

Close and reopen Adobe Acrobat® and activate your copy of TicTie Calculate.

  Important:

If you receive an error showing you have exceeded your maximum installs, please call, chat or email the support desk. We can release any licenses needed for activation.

Phone: +1 (855) 818-3552

Email: support@safesend.com 

Was this article helpful?
5 out of 10 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.